Scheduled for November 10, 2025 at 7:00 AM – 10:24 AM
Affects
Inbound Calling Services
Under maintenance from 7:00 AM to 10:24 AM
Inbound Calling
Under maintenance from 7:00 AM to 10:24 AM
Inbound Toll-Free Calling
Under maintenance from 7:00 AM to 10:24 AM
Outbound Calling Services
Under maintenance from 7:00 AM to 10:24 AM
Outbound Calling
Under maintenance from 7:00 AM to 10:24 AM
Outbound Toll-Free Calling
Under maintenance from 7:00 AM to 10:24 AM
Updates
Completed
November 10, 2025 at 10:24 AM
Completed
November 10, 2025 at 10:24 AM
Maintenance has completed successfully. No connected calls were affected, but a really small percentage of devices failed to re-register and appear down at the moment. We expect a number of these will retry after a set timeout, but you should verify that your device is correctly registered to receive calls.
In progress
November 10, 2025 at 7:00 AM
In progress
November 10, 2025 at 7:00 AM
Maintenance is now in progress
Planned
November 10, 2025 at 7:00 AM
Planned
November 10, 2025 at 7:00 AM
T38Fax engineers will be carrying out a series of hardware and software upgrades to add further scaling and resiliency to our Power-T.38 SIP trunking service.
The maintenance will begin at 2 AM (EST) and take up to 4 hours, completing by 6 AM at the latest. We do anticipate a brief interruption of calls for not more than 5 minutes, once or twice during this maintenance.
This is the replacement maintenance for the one that had to be postponed earlier this week.