Trouble accessing my.t38fax.com

Resolved
Degraded performance
Started 11 months ago Lasted 17 minutes

Affected

Portals
User Portal
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are investigating reports of trouble logging into the my.t38fax.com customer portal.
    Calls are not affected, but customers may have trouble logging in to manage their accounts.