Higher PDD than usual on outbound calls

Resolved
Operational
Started about 1 year ago Lasted about 5 hours

Affected

Outbound Calling Services
Outbound Calling
Outbound Toll-Free Calling
Updates
  • Resolved
    Resolved

    Calls continue to connect without high PDD. We are now closing this incident.

  • Identified
    Identified

    The problem has been identified and we implemented a fix. All calls appear to be connecting normally now.

    We will continue to monitor.

  • Investigating
    Investigating

    We noticed a higher delay in call establishment than usual, sometimes even preventing calls from connecting. We are investigating the cause of this.