Degraded call performance

Resolved
Operational
Started over 1 year ago Lasted about 3 hours

Affected

Inbound Calling Services
Inbound Calling
Inbound Toll-Free Calling
Outbound Calling Services
Outbound Calling
Outbound Toll-Free Calling
Updates
  • Resolved
    Resolved

    All services are responding normally at this time and have been since our last update. We are investigating root cause.

  • Monitoring
    Monitoring

    All calls are processing normally now, but we are closely monitoring the network while we investigate root cause.

  • Investigating
    Update

    We have confirmed degraded performance on new call setups and are working on a repair.

  • Investigating
    Investigating

    Engineers are currently investigating reports of new call establishment degraded performance affecting both incoming and outgoing calls. Updates will be reported here.