Call completion problems on inbound calls for a small number of customers.

Resolved
Degraded performance
Started 21 days ago Lasted about 7 hours

Affected

Inbound Calling Services
Inbound Calling
Inbound Toll-Free Calling
Updates
  • Resolved
    Resolved

    All calls have been connecting normally since the fix has been implemented. This issue is now considered resolved.

  • Monitoring
    Monitoring

    A fix has been implemented. We are currently monitoring.

  • Identified
    Identified

    We identified the issue. We are moving affected customers to different systems while working on a permanent fix.

  • Investigating
    Investigating

    A small number of customers are currently unable to receive calls as their inbound calls are not completing correctly.

    We are currently investigating this incident.